Metasploit The Penetration Tester's Guide Part 2




Metasploit is one of the most powerful tools used for penetration testing. Most resources can be found at Metasploit. Appears in two versions: free and commercial editions. There is no big difference in the two versions, so in this tutorial, we will mostly use the Community (free) version of Metasploit.

As an Ethical Hacker, you would use "Time Distribution" which has the version of Metasploit community embedded in it along with ethical hacking tools more. But if you want to install Metasploit as a separate tool, you can easily do this on systems that run on Linux, Windows, or Mac OS X.



Hardware requirements to install Metasploit is-
2 GHz & plus; processor
1 GB available RAM
1 GB & plus; available disk space

Matasploit can be used either with the command prompt or with Web UI.
the recommended version of the OS for Metasploit is:

Kali Linux Version 2.0 or Above
Backwards 3 and above Versions
Red Hat Enterprise Linux 5.10 Server
Red Hat Enterprise Linux Server 6.5
Red Hat Enterprise Linux Server 7.1
Ubuntu 10:04 LTS
Ubuntu 12.04 LTS
Ubuntu 14.04 LTS
Windows Server 2008 R2
Windows Server 2012 R2
Windows 7
Windows 8.1



Next
Previous
Click here for Comments

0 comments: